
FLASHport™ Software
User’s Guide

ASTRO® 25 Mobile Radios

ASTRO® 25 Portable Radios

¨

for

and



SOFTWARE LICENSE AGREEMENT
License
In this license agreement (“License Agreement”), you, the purchaser of the license rights granted by this Agreement, 
are referred to as “Licensee” or “You. “In accordance with the terms and conditions of this License Agreement, 
Motorola Corporation (“Licensor”) grants Licensee the non-exclusive license to use the accompanying software 
(“Software”) and documentation (“Documentation”) only in the country where acquired from your supplier (“Supplier”). 
In this License Agreement, the Software and Documentation and any copies or modifications are referred to as the 
“Licensed Product.” All rights to and in the Licensed FLASHport® Product, including, but not limited to, copyrights and 
trade secret rights, belong to Licensor and Licensor holds title to each copy of the Software. The Software shall only 
be used on a single computer at a time. Licensee shall not transfer or distribute the Licensed Product to others, and 
this Agreement shall automatically terminate in the event of such a transfer or distribution. Licensee shall not copy, 
modify, decompile, or reverse engineer the Licensed FLASHport Product. 

Term
This License Agreement is effective until terminated. Licensee may terminate this License Agreement by returning the 
Licensed Product to Licensor. Licensor may terminate this License Agreement without notice if Licensee breaches 
any of the terms and conditions. Upon termination of this License Agreement for any reason, Licensee shall 
immediately return the Licensed Product to Licensor. All provisions of this Agreement relating to disclaimers of 
warranties, limitation of liability, remedies or damages, and Licensor's proprietary rights shall survive termination. 
Object Code The Software is delivered in object code only. Licensee shall not reverse compile or otherwise reverse 
engineer the Software. 

Transfers
If Licensee transfers ownership of Products to a third party, Licensee may assign its rights to use Motorola Software 
(other than Radio Service Software and FLASHport Software) embedded in or furnished for use with those Products 
provided that (a) Licensee transfers all copies of such Motorola Software to the new owner and (b) Motorola receives 
a transfer form (which Motorola will provide upon request) completed and signed by the new owner. Otherwise, 
Licensee may not transfer or make available any Motorola Software to any third party. 

Limited Warranty 
For the first 120 days after initial shipment of Motorola Software, or, if the Motorola Software is provided pursuant to a 
Communications System Agreement or Communications Equipment Agreement between Motorola and Licensee, for 
the Warranty Period specified in such Agreement, Motorola warrants that the Motorola Software, when used properly, 
will be free from reproducible defects that eliminates the functionality of a feature critical to the primary functionality of 
a system. The primary functionality of a voice communication system is subscriber-to-subscriber, subscriber-to-
dispatcher, and dispatcher-to- subscriber voice communication. The primary functionality of a data system is point-to-
point data transmission. Motorola does not warrant that Licensee's use of the Motorola Software or the Products will 
be uninterrupted or error-free or that the Motorola Software or the Products will meet Licensee's particular 
requirements. This limited software warranty does not include any warranty covering the processing of date data from, 
into, and between the year 1999 and the year 2001. Any such warranty would be provided expressly in a separately 
executed agreement. MOTOROLA'S TOTAL LIABILITY, AND LICENSEE'S SOLE REMEDY, FOR ANY BREACH OF 
THIS WARRANTY WILL BE LIMITED TO, AT MOTOROLA'S OPTION, REPAIR OR REPLACEMENT OF THE 
MOTOROLA SOFTWARE OR PAYMENT OF LICENSEE'S DIRECT DAMAGES UP TO THE AMOUNT PAID TO 
MOTOROLA FOR THE MOTOROLA SOFTWARE OR THE INDIVIDUAL PRODUCT IN WHICH THE MOTOROLA 
SOFTWARE IS EMBEDDED OR FOR WHICH IT WAS PROVIDED. THIS WARRANTY EXTENDS ONLY TO THE 
FIRST LICENSEE; SUBSEQUENT TRANSFEREES MUST ACCEPT THE MOTOROLA SOFTWARE “AS IS” AND 
WITH NO WARRANTIES OF ANY KIND. MOTOROLA DISCLAIMS ALL OTHER WARRANTIES, EXPRESS OR 
IMPLIED, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR 
PURPOSE. 

Limitation of Liability 
Licensor's sole obligation or liability under this agreement is the replacement of defective media according to the 
Limited Warranty above. In no event will Licensor be liable for any consequential, incidental or indirect damages, 
including, without limitation, any loss of data, or loss of profits or lost savings, arising out of use or inability to use the 
Software or Documentation (or any hardware furnished with the software), even if Licensor has been advised of the 
possibility of such damages, or for any claim by any third party. In no event shall Licensor be liable for any damages. 

General
Any hardware provided to Licensee by Licensor shall not be exported or re-exported in violation of any export 
provisions of the United States or any other applicable jurisdiction. Any attempt to sublicense, assign or transfer any 
of the rights, duties or obligations hereunder is void. This Agreement shall be governed by and interpreted under the 
laws of the State of New York, United States of America, without regard to conflicts of provisions. In the case of the 
United States Government or an agency thereof as Licensee, the following additional terms apply: Restricted 
Computer Software, as defined in the Rights in Data-General clause at Federal Acquisition Regulations 52.227-14; 
and as applicable.

Restricted Rights Legend
Use, duplication, or disclosure by the Government is subject to restrictions as set forth in subparagraph (c) (1) (iii) of 
the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013.
Motorola Inc. Schaumburg, IL 60196
Licensee acknowledges that it has read and understands this agreement and agrees to be bound by its terms. 
Licensee further agrees that this agreement is the complete and exclusive statement of the agreement between the 
Licensee and Licensor, and supersedes any proposal or prior agreement, oral or written, and any other 
communications relating to this subject matter of this agreement.
MOTOROLA, the stylized M logo and ASTRO are registered in the US Patent and Trademark Office. All other product 
or service names are the property of their respective owners.
© Motorola, Inc. 2003, 2005.
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The Motorola equipment described in this manual may include 
copyrighted Motorola computer programs stored in semiconductor 
memories or other media. Laws in the United States and other 
countries preserve for Motorola certain exclusive rights for 
copyrighted computer programs, including the exclusive right to 
copy or reproduce in any form the copyrighted computer program. 
Accordingly, any copyrighted Motorola computer programs 
contained in the Motorola equipment described in this manual may 
not be copied or reproduced in any manner without the express 
permission of Motorola. Furthermore, the purchase of Motorola 
equipment shall not be deemed to grant either directly or by 
implication, estoppel, or otherwise, any license under the 
copyrights, patents or patent applications of Motorola, except for 
the normal nonexclusive, royalty free license to use that arises by 
operation of law in the sales of a product.

Computer Software Copyrights
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IntroductionIntroduction to FLASHport™

Congratulations! You have just purchased a software upgrade 
that will use FLASHport technology from Motorola! FLASHport is a 
revolutionary new method that makes it possible to add software 
capabilities to your radios both at the time of purchase and later on. 
Previously, changing radio features and capabilities meant costly 
hardware modifications or buying a new radio. But now, similar to 
how a computer can be loaded with different software, your radio’s 
features and capabilities can be upgraded with FLASHport 
software. This gives your Motorola radio the ability to meet your 
needs both today and in the future.

• System software packages provide basic radio control 
operations

• Enhancement packages build on systems packages and 
permit specific features to be installed in your radio.
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How to Use This Manual
This manual is designed to help you upgrade your radios with 

your new FLASHport software package. 
The radio software included in the upgrade package must be 

installed with the help of the Customer Programming Software 
(CPS). This is provided as a separate application, and must be 
purchased and installed on your computer prior to beginning the 
radio upgrade.

The following sections of this guide apply to all upgrades:
• Getting Started
• Equipment Setup
Be sure to read through these sections before installing the 

radio upgrade software. Then, when you are ready to install the 
new radio upgrade software into the radio, you will proceed to 
“Upgrading Your Radio” on page 8. 
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FLASHport Upgrade Package
Your FLASHport upgrade package contains the following 

major items:

• FLASHport User’s Guide (this guide).

• CD-ROM disk(s) containing the 
FLASHport software files.

• New iButton® FLASHkey™ which has 
been programmed with the aftermarket 
order information.

• “I’ve Been FLASHED” stickers which 
allow you to mark each radio that has 
been upgraded

• New radio labels to add and/or replace 
the existing labels on the back of the 
radios. These labels identify the system 
package purchased and the radios’ 
new FLASHcode.

ASTRO  XTS 2500 ,

XTS 5000  DIGITAL

PORTABLE RADIOS

ASTRO  DIGITAL

SPECTRA  PLUS

MOBILE RADIOS
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Getting StartedItems You Will Need to Get Started
Most of the items needed to perform a FLASHport upgrade are 

standard items required for any radio programming using Customer 
Programming Software (CPS).

• Computer (For use with 
CPS)
Processor: 400 MHz (or higher) 
Pentium grade processor
Memory: 128 MB RAM (Win 98/
98SE/ME / Win NT 4.0 SP6+ / 
Win2000); 256 MB RAM or 
higher for Windows XP (Home 
or Professional)
Hard Disk Space: 1 Gigabyte 
drive with 450 MB minimum free 
space

Peripherals: 
— Microsoft Windows supported mouse or trackball
— Microsoft Windows supported serial port for radio 

communication
— USB port for Windows 2000 SP2 or higher or Windows XP 

SP1 or higher (optional)
— Microsoft Windows supported printer port for report printing
— 1.44 MB 3.5” floppy disk drive
— CD-ROM for software installation
— internet access
— Windows email application for application email support
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• FLASHkey
Included with the upgrade 
package. Connects to either the 
parallel port or the USB port on 
the computer, depending on the 
iButton adapter.

• FLASHport Software 
Disk(s)
Included with the upgrade 
package.

• RS-232 Programming 
and Test Cable
RKN4106 for XTS 2500, XTS 
5000, XTS 1500, MT 1500 and 
PR 1500.
RKN4122 for SSE 5000

• USB Programming and 
Test Cable
RKN4105 for XTS 2500, XTS 
5000, XTS 1500, MT 1500 and 
PR 1500.
RKN4121 for SSE 5000

ASTRO  XTS 2500 ,

XTS 5000  DIGITAL

PORTABLE RADIOS

ASTRO  DIGITAL

SPECTRA  PLUS

MOBILE RADIOS
¤
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¤
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• HKN6155 Programming Cable
For ASTRO Digital Spectra Plus and XTL 5000
XTL 5000 Mid-Power with W3, W4, W5, W7 or W9 Control 
Head.

• HKN6183 Programming Cable (GCAI )
XTL 5000 High-Power with W3, W4, W5, W7 or W9 Control 
Head.
XTL 5000 with O5 Control Head.
XTL 2500 and XTL 1500.

• Radios
— ASTRO 25 Portable: XTS 5000, XTS 2500, XTS 1500, 

MT 1500, PR 1500, SSE 5000
— ASTRO 25 Mobile: XTL 5000, XTL 2500, XTL 1500, 

ASTRO Digital Spectra Plus

• Customer Programming Software (CPS)
— For ASTRO 25 Portable:

- CPS/Tuner — RVN4181
— For ASTRO 25 Mobile:

- CPS/Tuner — RVN4185
— For ASTRO 25 Portable and ASTRO 25 Mobile 

Combined Package:
- CPS/Tuner — RVN4186
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Equipment Setup
To begin your FLASHport upgrade, connect the equipment as 

shown below.

A complete description of the equipment is provided in “Items 
You Will Need to Get Started” on page 4. 

Note: FLASHport via USB is supported only for ASTRO 25 
portable radios.

Note: For XTL 5000 with O5 control head, XTL 2500 and XTL 1500 
radios, it is very important to connect the programming cable 
directly into the control head even for remote mounted 
configurations. 

MTS 2000

Radio
To Computer’s

Com or USB Port

RS-232 or USB
Programming Test Cable

Note: The FLASHkey is connected to the computer’s
parallel port or USB port.
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Upgrading Your RadioUpgrading Your Radio Using CPS
This section provides instructions on how to upgrade or 

“FLASH” your radio with new features using the Customer 
Programming Software (CPS).

“FLASHing” Procedure (CPS)
“FLASHing” or upgrading your radio requires the Customer 

Programming Software (CPS) which is used during normal radio 
programming and servicing procedures. Refer to the “Getting 
Started” section for your radio’s specific CPS part number. The 
following steps describe the best method to upgrade your radio.

Note: To save time, perform upgrades of the same model type 
consecutively. (Example: XTS 5000 Model 1 radio followed 
by an XTS 5000 Model 1 radio.)

1. Your FLASHport software upgrade package includes one 
piece of software (FLASHport upgrade software) on CD-ROM. 
Before starting the upgrade procedure, copy the software to 
your PC hard drive.

2. Connect the equipment as shown on page 7 of this guide. 
Make sure the radio is equipped with a charged battery 
(portables) or an external power supply (mobiles).

3. Apply power to the radio. The radio should turn on and go 
through its power-up sequence.

Note: Do not disconnect your radio until the FLASHport upgrade 
process is completely finished.
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4. Launch the CPS program by selecting: 
Start → Programs → Motorola → <ASTRO 25 Family> → 

<ASTRO 25 Portable CPS> 
(Note that the items listed in italics between < > will vary 
depending on the type of radio you are upgrading; make the 
selections appropriate to the radio type (e.g., XTS 5000 radio, 
XTS 2500 radio, etc.).

5. From the menu bar in the CPS main window, select:
Tools → FLASHport → Read Radio Configuration

The following Read Radio Configuration screen will appear. Make 
sure the Port setting is correct and click on OK.
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6. The following View Radio Configuration screen will appear. 
Make a note of the FLASHcode and System Package fields 
currently set for the radio. After the upgrade, you’ll re-examine 
this screen to make sure the upgrade was successful. (Note 
that you can click on the Details button to view the features 
currently enabled on this radio.)

7. Close the View Radio Configuration screen. From the menu 
bar in the CPS main window, select:

Tools → FLASHport → Read FlashKey Configuration

The following Read FLASHkey Configuration screen will 
appear.
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Be sure to read and heed the notice and warning on the 
screen. Click on OK to proceed.

8. The FLASHkey Configuration will be read and the View 
FLASHkey Configuration screen will appear.

More data is displayed if a full upgrade FLASHkey is read; less 
data appears if a refresh FLASHkey is read.
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9. From the menu bar in the CPS main window, select

Tools → FLASHport → Upgrade Radio

10. The Upgrade Radio screen will appear. Using the Browse 
button at the end of the edit control, navigate to the location of 
the new radio software file (copied to your PC in Step 1), verify 
that the directory paths in the Current Settings area are correct 
(typically valid unless you have moved files, in which case 
you’ll have to select the proper paths), then click OK.

Note: Regarding the UCM Upgrade Path & Filename field, the 
UCM (Universal Crypto Module) is used for radios equipped 
with Secure Encryption. This field is only used if the radio 
contains a UCM module and the module software will be 
upgraded.
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11. The FLASHing Radio... screen will appear. The new software 
will begin loading into the radio, as indicated by a progress bar 
at the bottom of the screen.

Note: For the XTL 5000 with O5 control head, XTL 2500 and XTL 
1500 radios, the FLASHport process takes longer than other 
mobile radios due to the fact that these new control heads 
now contain upgradeable software.

12. When the software has completed loading into the radio, the 
following screen will appear. 
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13. Repeat Step 5 to verify that the new software version appears 
in the FLASHcode and System Package fields. You may also 
click on the Details button to verify that any new features have 
been enabled.

14. Once your radio has been successfully “FLASHed,” you are 
free to use the CPS to enter any customer-specific information 
normally contained within the CPS. After CPS programming is 
complete, save the codeplug data to an archive file. You may 
upgrade another radio by repeating Steps 5 through 12 (pages 
9 through 13).

After completing the upgrade, disconnect the radio. Replace 
and/or add the radio label with the new radio label provided. It is 
very important that the new labels are placed on each 
“FLASHed” radio so that the radios can be identified for future 
service and programming.

To help identify the radios that have already been upgraded, 
place an “I’ve been FLASHED” sticker on the outside of the radio. 
These stickers can be easily removed by the end-user.

A FLASHcard should be given to the end-user with each radio 
upgraded. This FLASHcard provides the end-user with a quick 
reference of the new features that the radio now contains due to the 
upgrade. 
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Troubleshooting HintsTroubleshooting Hints

Encaten Error 
Messages Possible Corrective Actions

Unable to create instance of 
Encaten Component

This is an error with the file EncatenCompo-
nent.dll. It is either not installed correctly or not 
registered. You may search for that file and if it is 
found then attempt to register the file (make 
sure CPS is closed before attempting this step) 
by going to Start->Run and typing in the follow-
ing command: regsvr32 <full path>\Encaten-
Component.dll
If that does not work, then try uninstaling and 
then reinstalling CPS. 

Software Upgrade Kit 
Errors Possible Corrective Actions

Error extracting bootcode 
from upgrade file

This is an error with the software upgrade kit. It 
is either corrupted or an error occurred while 
extracting the bootcode software. Verify that the 
correct software upgrade kit has been selected.

Error Opening Flash 
Upgrade File

This is an error with the software upgrade kit. It 
is either corrupted or the application cannot 
locate the file.

Bootcode Not Present! This is an error with the software upgrade kit. It 
is either corrupted or does not contain the 
required bootcode. Verify that correct software 
upgrade kit has been selected.

Error extracting radio appli-
cation software from upgrade 
file

This is an error with the software upgrade kit. It 
is either corrupted or error occurred while 
extracting the HOST software. Verify that the 
correct software upgrade kit has been selected.
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Host Code Not Present! This is an error with the software upgrade kit. It 
is either corrupted or does not contain the 
required HOST software. Verify that the correct 
software upgrade kit has been selected.

Error extracting DSP soft-
ware from upgrade file

This is an error with the software upgrade kit. It 
is either corrupted or error occurred while 
extracting the DSP software. Verify that the cor-
rect software upgrade kit has been selected.

Checksum Error in the Flash 
Upgrade File.

This is an error with the software upgrade kit. It 
is corrupted and does not contain a valid check-
sum.

Dsp Code Not Present! This is an error with the software upgrade kit. It 
is either corrupted or does not contain the 
required DSP code. Verify that correct software 
upgrade kit has been selected.

Error Opening Flash 
Upgrade File

This is an error with the software upgrade kit. It 
is either corrupted or the application cannot 
locate it. Verify that the correct software upgrade 
kit has been selected and that the user has per-
missions to read the file.

There is a FLASH file and 
hardware mismatch

This is an error with the software upgrade kit. 
The file does not have the correct radio type for 
the radio being upgraded. Verify that the correct 
software upgrade kit has been selected. 

Invalid Upgrade File Format This is an error with the software upgrade kit. It 
is either corrupted or the contents of it are incor-
rect. Verify that the correct software upgrade kit 
has been selected.

Error encountered while 
handling the Flash Upgrade 
File.

This error means that the application had prob-
lems extracting data from the software upgrade 
kit. Verify that the correct software upgrade kit 
has been selected.
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Error encountered while vali-
dating Flash Upgrade File

This error means that the application had prob-
lems validating the data in the software upgrade 
kit. Verify that the correct software upgrade kit 
has been selected.

FLASHkey Errors Possible Corrective Actions

Upgrades Expired! This is an error of the FLASHkey. The number of 
upgrades remaining in the FLASHkey is zero so 
no more upgrades are available. Verify 
upgrades from the CPS Menubar (Tools-
>FLASHport->Read FLASHkey Configuration). 
If upgrades remaining are zero, a new FLASH-
key is needed.

Invalid Current Flash Code Current FLASHcode in the radio does not match 
the Current FLASHcode value in the FLASHkey. 
Verify that the correct FLASHkey is attached.

Invalid Internal Codeplug 
Version

This is an error with the FLASHkey. The internal 
codeplug version of the FLASHkey is not sup-
ported by the  application. A new FLASHkey is 
needed.

Invalid External Codeplug 
Version

This is an error with the FLASHkey. The external 
codeplug version of the FLASHkey is not sup-
ported by the  application. A new FLASHkey is 
needed

Invalid Radio Model Number This is an error with the FLASHkey. The FLASH-
key's model number does not match the model 
number of the radio being upgraded. Verify that 
the correct FLASHkey is attached from the CPS 
Menubar (Tools->FLASHport->Read FLASH-
key Configuration) to confirm this.
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This radio can only be 
refreshed. The FLASHkey 
must be a refresh key.

This is an error with the FLASHkey. Some 
radios can only be refreshed therefore only a 
Refresh FLASHkey can be used. Verify that the 
correct FLASHkey is attached from the CPS 
Menubar (Tools->FLASHport->Read FLASH-
key Configuration). From this Read FLASHkey 
screen, confirm that in the model number field, 
the value "REFRESH FLASHKEY" appears.

FLASHkey ID Verify Error - 
Upgrade Aborted

This is an error with the FLASHkey. The applica-
tion was unable to validate the FLASHkey. Verify 
that the FLASHkey is connected properly from 
the CPS Menubar (Tools->FLASHport->Read 
FLASHkey Configuration). If unable to read, the 
FLASHkey must have been corrupted and a 
new FLASHkey is needed.

FLASHkey Data Read Error This is an error with the FLASHkey. The applica-
tion was unable to read the FLASHkey data. 
Verify that the FLASHkey is connected properly 
from the CPS Menubar (Tools->FLASHport-
>Read FLASHkey Configuration). If unable to 
read, the FLASHkey must have been corrupted 
and a new FLASHkey is needed.

The FLASH Upgrade Failed!! 
Cannot read the FLASH-
key.\nVerify that the FLASH-
key is properly connected.

This is an error with the FLASHkey. The CPS 
was unable to read the FLASHkey. Verify that 
the FLASHkey is connected properly from the 
CPS Menubar (Tools->FLASHport->Read 
FLASHkey Configuration). If unable to read, the 
FLASHkey must have been corrupted and a 
new FLASHkey is needed.

Invalid FLASHkey This is an error with the FLASHkey. The refresh 
FLASHkey connected is invalid. Verify that the 
FLASHkey is connected properly from the CPS 
Menubar (Tools->FLASHport->Read FLASH-
key Configuration). If unable to read, the 
FLASHkey must have been corrupted and a 
new FLASHkey is needed.
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Communications Errors Possible Corrective Actions

Error reading date code This is an error reading specific data from the 
radio. Most likely a communication problem 
occurred. Check for loose cables and retry the 
upgrade. If the problem persists, try using a dif-
ferent cable or computer.

Error reading FLASHcode This is an error reading specific data from the 
radio. Most likely a communication problem 
occurred. Check for loose cables and retry the 
upgrade. If the problem persists, try using a dif-
ferent cable or computer.

Error reading serial number This is an error reading specific data from the 
radio. Most likely a communication problem 
occurred. Check for loose cables and retry the 
upgrade. If the problem persists, try using a dif-
ferent cable or computer.

Error reading model 
definition flag - FLASHport 
capable flag

This is an error reading specific data from the 
radio. Most likely a communication problem 
occurred. Check for loose cables and retry the 
upgrade. If the problem persists, try using a dif-
ferent cable or computer.

Error writing post flash data This is an error writing specific data to the radio. 
Most likely a communication problem occurred. 
Check for loose cables and retry the upgrade. If 
the problem persists, try using a different cable 
or computer

Error programming the 
codeplug

This is an error writing the codeplug to the radio. 
Most likely a communication problem occurred. 
Check for loose cables and retry the upgrade. If 
the problem persists, try using a different cable 
or computer.
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Error reading the codeplug This is an error reading the codeplug from the 
radio. Most likely a communication problem 
occurred. Check for loose cables and retry the 
upgrade. If the problem persists, try using a dif-
ferent cable or computer.

Error reading system 
enhancement bytes

This is an error reading specific data from the 
radio. Most likely a communication problem 
occurred. Check for loose cables and retry the 
upgrade. If the problem persists, try using a dif-
ferent cable or computer.

Error reading radio type This is an error reading specific data from the 
radio. Most likely a communication problem 
occurred. Check for loose cables and retry the 
upgrade. If the problem persists, try using a dif-
ferent cable or computer.

Error reading radio 
processor type

This is an error reading specific data from the 
radio. Most likely a communication problem 
occurred. Check for loose cables and retry the 
upgrade. If the problem persists, try using a dif-
ferent cable or computer.

Failed to download bootcode This is an error while downloading the boot-
loader into the radio. Most likely a communica-
tion problem occurred. Check for loose cables 
and retry the upgrade. If the problem persists, 
try using a different cable or computer.

Failed to upgrade the host This is an error while upgrading the Host soft-
ware in the radio. If the upgrade failed while 
upgrading host code, the radio will most likely 
power up in bootmode. Retry the upgrade.

Failed to upgrade the DSP This is an error while upgrading the DSP soft-
ware in the radio. Most likely a communication 
problem occurred. Check for loose cables and 
retry the upgrade. If the problem persists, try 
using a different cable or computer.
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Failed to unlock the radio This is an error when unlocking the radio. Most 
likely a communication problem occurred. 
Check for loose cables and retry the upgrade. If 
the problem persists, try using a different cable 
or computer.

Failed to read a radio 
component's version

This is an error reading specific data from the 
radio. Most likely a communication problem 
occurred. Check for loose cables. Check for 
loose cables and retry the upgrade. If the prob-
lem persists, try using a different cable or com-
puter.

Failed to open the port This is an error having to do with failing to open 
communications with the radio. Check the con-
nections and the cables. Try reading the radio. 
From the  menubar select (File->Read Device) 
to see if a problem occurs. If successful, request 
user to reset the radio and retry the upgrade. If 
the problem persists, try using a different cable 
or computer.

Radio failed to reset This is an error having to do with the radio failing 
to reset. Therefore manually reset the radio. 
Check for loose cables and retry the upgrade. If 
the problem persists, try using a different cable 
or computer.

The Radio Failed to Boot-
strap - Check All Cables

This error occurs because the radio is unable to 
enter bootmode. Most likely a communication 
problem occurred. Check for loose cables and 
retry the upgrade. If the problem persists, try 
using a different cable or computer.

Failed to download bootcode This error occurs because the  was unable to 
download the bootcode software into the radio. 
Most likely a communication problem occurred. 
Check for loose cables and retry the upgrade. If 
the problem persists, try using a different cable 
or computer.
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Failed to enter into Program 
Mode

Error while trying to put the radio in program 
mode. Most likely a communication problem 
occurred. Check for loose cables. Request user 
to retry the upgrade. If the problem persists, try 
using a different cable or computer.

Unable to read the RSSI 
DSP Offset from the tuning 
partition

This error happens only in mobile ASTRO Spec-
tra Plus radios. It will not cause the upgrade to 
abort. The upgrade will continue anyways. 
When the upgrade completes, if the tuning parti-
tion was upgraded (see the status of the 
FLASHport upgrade) then the radio may need a 
cpfix solution to fix a value in the tuning partition 
that can cause issues with radio operation.

Unable to reprogram the 
RSSI DSP Offset to the tun-
ing partition

This error could happen only in mobile ASTRO 
Spectra Plus radios. It will not cause the 
upgrade to abort. The upgrade will continue 
anyways. When the upgrade completes, if the 
tuning partition was upgraded (see the status of 
the FLASHport upgrade) then the radio may 
need a cpfix solution to fix a value in the tuning 
partition that can cause issues with radio opera-
tion.

Error encountered during 
flash radio

This error indicates that the  was unable to com-
pletely upgrade the radio. Most likely a commu-
nication problem occurred. Check for loose 
cables. Request user to retry the upgrade. If the 
problem persists, try using a different cable or 
computer.

Error encountered in update 
firmware

This error indicates that the  was unable to 
upgrade one of the components in the radio. 
Most likely a communication problem occurred. 
Check for loose cables. Request user to retry 
the upgrade. If the problem persists, try using a 
different cable or computer.
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Fixed Structure 
Codeplug Errors Possible Corrective Actions

ERROR - Cannot proceed 
with FLASH Upgrade when 
the codeplug has more than 
one ASTRO System.\n 
Please remove the additional 
ASTRO Systems and try 
again!

This error only appears in the portable  when 
upgrading to add the Conventional Radio Clon-
ing option. The codeplug in the radio must have 
a special structure in order for the upgrade to 
continue. This error is appears when the code-
plug has more than one ASTRO system. 

ERROR - Cannot proceed 
with FLASH Upgrade when 
the codeplug has more than 
240 Conventional 
Personalities.\n Please 
remove the additional 
Conventional Personalities 
and try again!

This error only appears in the portable  when 
upgrading to add the Conventional Radio Clon-
ing option. The codeplug in the radio must have 
a special structure in order for the upgrade to 
continue. This error appears when the codeplug 
has more than 240 Conventional Personalities.

ERROR - Cannot proceed 
with FLASH Upgrade when 
the codeplug has more than 
15 Zones.\n Please remove 
the additional Zones and try 
again!

This error only appears in the portable  when 
when upgrading to add the Conventional Radio 
Cloning option. The codeplug in the radio must 
have a special structure in order for the upgrade 
to continue. This error appears when the code-
plug has more than 15 Zones.

ERROR - Cannot proceed 
with FLASH Upgrade when 
the codeplug has more than 
16 Channels in each Zone.\n 
Please remove the additional 
Channels and try again!

This error only appears in the portable when 
upgrading to add the Conventional Radio Clon-
ing option. The codeplug in the radio must have 
a special structure in order for the upgrade to 
continue. This error appears when the codeplug 
has more than 16 Channels in a zone.
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USB Related Errors Possible Corrective Actions

The currently selected 
FLASHport Upgrade file 
cannot be used for USB 
FLASHport.

This error may be due to software upgrade kit 
version. To be able to use USB communications 
in FLASHport, the bootcode software in the 
upgrade kit must be of at least a specific version 
or higher. This error appears if the version of the 
bootcode in the upgrade kit is older than what is 
needed for USB.

Error validating Flash RAM 
Downloader in upgrade file

This error may be due to software upgrade kit 
version. To be able to use USB communications 
in FLASHport, the bootcode software in the 
upgrade kit must be of at least a specific version 
or higher. This error specifies that CPS was 
unable for some reason to do that verification. 
Retry the upgrade.

Failed to install Motorola 
XTS FLASHzap Device. 
Please reset your radio.

This error will occur if the FLASHzap Device 
was not installed correctly (this is not a CPS 
installation issue). The FLASHzap device is 
installed when USB is to be used for the first 
time for FLASHport upgrades in the specific 
machine. The installation of the device occurs 
automatically when the radio is put in bootmode 
and while connected through USB.

UCM Upgrade Errors Possible Corrective Actions

Radio contains a Type I 
Encryption Module. Unable 
to upgrade this module type.

This error can be caused if the UCM in the radio 
is a Type I UCM module. The CPS is unable to 
upgrade it. UCM must be upgraded using other 
equipment available for type I modules

Invalid UCM Upgrade File This is an error of the UCM upgrade file. The for-
mat and/or contents of the file are not valid. Ver-
ify that the correct UCM upgrade file has been 
selected. If so, the file may be corrupt or invalid 
so a new file will be needed to complete the 
UCM upgrade.
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You need a secure enabled 
codeplug to upgrade the 
Secure Encryption Module in 
your radio.  Please 
reprogram your radio with a 
secure enabled codeplug 
and try again. Aborting 
upgrade...

This is an error of the UCM upgrade. This mes-
sage appears if the codeplug in the radio does 
not have the Secure Equipped feature enabled. 
Enable Secure Equipped in the codeplug, re-
write the codeplug to the radio and then try the 
upgrade again. 

Secure Encryption Module 
Upgrade Failed

This is a generic error condition for UCM 
upgrade failures.

Other Errors Possible Corrective Actions

This Radio is NOT FLASH-
portable!

This error indicates that the attached radio can-
not be upgraded. Verify that correct radio is 
attached.

This Radio has an Invalid 
Serial Number - Upgrade 
Aborted

This error indicates that the radio's serial num-
ber has incorrect nomenclature. Verify that the 
serial number in the radio is of correct nomen-
clature.

H-Option File Import Failure This is an error having to do with the hopt.mdf 
file. It is either corrupted or missing. It must be 
installed in the same directory as the  execut-
able files.

This Radio Cannot be 
FLASH Upgraded! The 
Controller Board Must be 
Initialized with a Proper 
Serial Number. Reset the 
Radio and Perform a 
Standard Read.

This error indicates that you are attempting to 
upgrade a CBI radio. Read the radio (File -> 
Read Device) and initialize the radio with the 
proper serial number.
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Unpack Codeplug Error - 
Upgrade Aborted

This is an error that occurred while trying to 
unpack the codeplug. From the CPS menubar, 
read the radio (File->Read Device) to see if an 
error occurs. If an error occurs, then there is 
something wrong with the codeplug. If an error 
does not occur, attempt the upgrade again.

Unable to Pack Codeplug - 
Upgrade Aborted

This is an error that occurred while trying to pack 
the codeplug. From the CPS try to read and 
write the radio to see if there are any problems 
with the codeplug. If an error occurs, then there 
is something wrong with the codeplug. If an 
error does not occur, attempt the upgrade again.

This Radio is not supported 
by this application

The radio connected is not supported by the 
CPS application. Verify that the correct CPS is 
being used to upgrade the radio.

Flash Not Performed - Radio 
Already Upgraded

This error only occurs in releases of CPS older 
than R05.00.00. This error indicates that the 
radio connected to the PC has already been 
upgraded with the attached FLASHkey. A new 
FLASHkey is needed to upgrade this radio.

Codeplug Upgrade Failed. This error indicates that the  was unable to 
upgrade the codeplug. There could be many 
reasons why this happens:
•      The model number of the radio cannot be 

found in the hopt.mdf file.
•      The FLASHcode is invalid.
•      An Enhancement Option is not found in the 

hopt.mdf file or it is not supported by the 
particular radio model.

FLASH Unknown Failure This is a generic error for unknown error condi-
tions. Most likely a communication problem 
occurred. Check for loose cables and retry the 
upgrade. If the problem persists, try using a dif-
ferent cable or computer.
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FLASHport Troubleshooting for the New 
ASTRO 25 Control Heads (XTL 5000 with O5 
Control Head, XTL 2500 and XTL 1500)

During remote flashing, if you get a CPS warning message 
that an error has occured, and telling you to reset your system, 
there are three possible states that the radio can power-up in: 
Normal Mode, Boot Mode and an Unresponsive Mode.

Normal Mode:
If the transceiver powers-up in Normal Mode, the programmed 
Zone/Channel information appears in the MCH’s (Mobile Control 
Head) display.

Boot Mode:
If the transceiver powers up in the Boot Mode, an “FL 01/90” error 
code appears in the MCH’s display:

• when a programming cable is attached to the control head, 
after a brief delay, the transceiver goes into “Maintenance 
Mode” (this appears in the MCH’s display).

• when a programming cable is not attached to the control 
head, the transceiver will continue to reset and display the 
“FL 01/90” error.

Unresponsive Mode:
If you are sure that the programming cable is securely attached, 
and yet the MCH continues to reset and display the “FL 01/90” 
error, it is possible that the transceiver is completely unresponsive 
and the entire radio has to be sent back for service. An 
unresponsive mode is caused by either the “bootapp” being 
corrupted during FLASHing or the Nautilus image of the transceiver 
in a remote mount configuration being corrupted during FLASHing.
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Note: If a FLASHing error occurs in the CPS instructing you to 
reset the system Off and then back On; and then once the 
MCH powers back up, if a spinning Motorola logo appears 
within the MCH display, clicking the “Retry” button at that 
point (from the error message that appears within the CPS) 
should recover the FLASHport process.
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